View Issue Details

IDProjectCategoryView StatusLast Update
0000124file[All Projects] Generalpublic2019-11-19 05:30
ReporterEssemAssigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.37 
Target VersionFixed in VersionHEAD 
Summary0000124: S3M files detected as mimetype application/octet-stream
DescriptionHello,

I was wondering whether file could report the mime type for S3M files, especially considering that other audio module formats are correctly reported. However, when I tried to check the mime type for these files, they were reported as a generic octet stream. This confused me especially since the source code references these files alongside their mime types in /magic/Magdir/audio at around line 128. Why is file/libmagic not reporting the correct mime type if it's defined in the code? An example file showing this behavior has been attached.
Steps To Reproduce$ file <filename>.s3m
<filename>.s3m: ScreamTracker III Module sound data Title: "<title>"
$ file --mime-type <filename>.s3m
<filename>.s3m: application/octet-stream
Tagsmagic

Activities

Essem

2019-11-14 17:13

reporter  

CLICK.S3M (295,008 bytes)

christos

2019-11-19 05:30

manager   ~0003334

Added.

Issue History

Date Modified Username Field Change
2019-11-14 17:13 Essem New Issue
2019-11-14 17:13 Essem File Added: CLICK.S3M
2019-11-14 17:13 Essem Tag Attached: magic
2019-11-19 05:30 christos Assigned To => christos
2019-11-19 05:30 christos Status new => assigned
2019-11-19 05:30 christos Status assigned => resolved
2019-11-19 05:30 christos Resolution open => fixed
2019-11-19 05:30 christos Fixed in Version => HEAD
2019-11-19 05:30 christos Note Added: 0003334