View Issue Details

IDProjectCategoryView StatusLast Update
0000154file[All Projects] Generalpublic2020-05-30 23:49
ReportergiovariotAssigned Tochristos 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.37 
Target VersionFixed in Version5.39 
Summary0000154: QTK File support missing
DescriptionThese files are recognized as data by file 5.37, installed by default on macOS. Here is their description.

I attached 3 files:
* image 7 is a Quicktake 100 high-resolution RAW file (can be opened with dcraw). First 12 bytes: "716B746B 00000008 0001C566" (qktkÅf)
* image 2 is a Quicktake 100 low-resolution RAW file (can be opened with dcraw). First 12 bytes: "716B746B 00000004 000073E6" (qktksæ)
* image 1 is a Quicktake 100 file, it has the same first 12 bytes as the high-resolution RAW file ("716B746B 00000008 0001C566" (qktkÅf)) but it cannot be opened neither by dcraw nor by graphicconverter on macOS, so I don't really know what it is.


Steps To Reproducefile <image.qtk>
Tagsmagic

Activities

giovariot

2020-04-05 17:32

reporter  

Image 7 - 24-09-2000.qtk (118,482 bytes)
Image 2 - 24-09-2000.qtk (32,082 bytes)
Image 1 - 24-09-2000.qtk (116,076 bytes)

christos

2020-05-30 23:49

manager   ~0003415

Added, thanks. Image1 cannot be loaded by dcraw because the place where it reads the resolution seems to have 0's. Parts of the header are missing.

Issue History

Date Modified Username Field Change
2020-04-05 17:32 giovariot New Issue
2020-04-05 17:32 giovariot File Added: Image 1 - 24-09-2000.qtk
2020-04-05 17:32 giovariot File Added: Image 2 - 24-09-2000.qtk
2020-04-05 17:32 giovariot File Added: Image 7 - 24-09-2000.qtk
2020-04-05 17:32 giovariot Tag Attached: magic
2020-05-30 23:49 christos Assigned To => christos
2020-05-30 23:49 christos Status new => assigned
2020-05-30 23:49 christos Status assigned => resolved
2020-05-30 23:49 christos Resolution open => fixed
2020-05-30 23:49 christos Fixed in Version => 5.39
2020-05-30 23:49 christos Note Added: 0003415