View Issue Details

IDProjectCategoryView StatusLast Update
0000210file[All Projects] Generalpublic2020-12-16 23:42
ReporterHelflymAssigned Tochristos 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.39 
Target VersionFixed in Version5.40 
Summary0000210: Wrong define for strndup workaround on AIX
DescriptionHi,

In softmagic.c (https://github.com/file/file/blob/master/src/softmagic.c#L501), there is a workaround in order to provide strndup if it doesn't exist on the target or on AIX as strndup isn't working as expected.
However, the define used for AIX "__aiws__" is unknown to me. It should be "_AIX". Does anyone remember if it's a mistake or if it was intended ?
In both case, "defined(_AIX)" should be added in order to make it work in all AIX versions or with all AIX compilers.

Thanks,
TagsNo tags attached.

Activities

christos

2020-12-16 23:42

manager   ~0003506

Fixed, thanks!

Issue History

Date Modified Username Field Change
2020-11-16 12:27 Helflym New Issue
2020-12-16 23:41 christos Assigned To => christos
2020-12-16 23:41 christos Status new => assigned
2020-12-16 23:42 christos Status assigned => resolved
2020-12-16 23:42 christos Resolution open => fixed
2020-12-16 23:42 christos Fixed in Version => 5.40
2020-12-16 23:42 christos Note Added: 0003506