View Issue Details

IDProjectCategoryView StatusLast Update
0000290file[All Projects] Generalpublic2021-10-28 15:32
ReporterChaoticRomanAssigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.40 
Target VersionFixed in Version 
Summary0000290: Wrong installation instructions in both INSTALL and README.DEVELOPER files
DescriptionIn the INSTALL, there are generic "./configure; make; make install" instructions but it seems that correct process is

autoreconf -f -i
./configure --disable-silent-rules
make
make install

In the README.DEVELOPER, there is

    autoreconf -f -i
    make distclean
    ./configure --disable-silent-rules
    make -j4
    make -C tests check

but "make distclean" would complain "make: *** No rule to make target distclean'".

Tested on Ubuntu 20.04 by myself.

Original report: https://stackoverflow.com/questions/69222631/46-regex-error-17-for-dryad-bibo-v0-9-0-9-match-failed
Steps To Reproduce./configure
autoreconf -f -i
make distclean
TagsNo tags attached.

Activities

christos

2021-09-20 14:05

manager   ~0003645

I added a comment that it can fail in README.DEVELOPER. The INSTALL file is fine because it instructs you to use 'make distclean' to cleanup after a previous build.

christos

2021-10-28 15:32

manager   ~0003652

Feedback timeout.

Issue History

Date Modified Username Field Change
2021-09-20 13:34 ChaoticRoman New Issue
2021-09-20 14:04 christos Assigned To => christos
2021-09-20 14:04 christos Status new => assigned
2021-09-20 14:05 christos Status assigned => feedback
2021-09-20 14:05 christos Note Added: 0003645
2021-10-28 15:32 christos Status feedback => resolved
2021-10-28 15:32 christos Resolution open => fixed
2021-10-28 15:32 christos Note Added: 0003652