View Issue Details

IDProjectCategoryView StatusLast Update
0000394fileGeneralpublic2022-10-10 18:46
Reporterulm Assigned Tochristos  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.43 
Fixed in VersionHEAD 
Summary0000394: Makefile misidentified as "PRO-PACK archive data", while file -i is correct
Descriptionfile-5.43 incorrectly reports "PRO-PACK archive data" for attached Makefile.
"file -i" reports it correctly as text/x-makefile.
Steps To Reproduce$ file Makefile
Makefile: PRO-PACK archive data
$ file -i Makefile
Makefile: text/x-makefile; charset=us-ascii
TagsNo tags attached.

Activities

ulm

2022-10-10 07:32

reporter  

Makefile (479 bytes)   
RNCS = devbook.rnc glsa.rnc metadata.rnc mirrors.rnc projects.rnc \
       repositories.rnc userinfo.rnc

ifneq ($(PV),)
P=nxml-gentoo-schemas-$(PV)
else
P=nxml-gentoo-schemas-$(shell TZ=UTC date '+%Y%m%d')
endif

.PHONY: all dist clean
.PRECIOUS: $(RNCS)

all: $(RNCS)

dist: Makefile LICENCE schemas.xml $(RNCS)
	tar -cJf $(P).tar.xz --transform='s%^%$(P)/%' $^

clean:
	rm -f *.tar.xz

%.rnc: dtd/%.dtd
	trang -I dtd -O rnc $< $@

devbook.rnc: devmanual/devbook.rnc
	cp $< $@
Makefile (479 bytes)   

ulm

2022-10-10 07:58

reporter   ~0003833

Here's some information about the Pro-Pack (aka RNC) header format:
https://www.segaretro.org/Rob_Northen_compression

Looks like requiring an additional byte 0x01 or 0x02 after "RNC" would mitigate the problem.

christos

2022-10-10 18:46

manager   ~0003834

Fixed. thanks!

Issue History

Date Modified Username Field Change
2022-10-10 07:32 ulm New Issue
2022-10-10 07:32 ulm File Added: Makefile
2022-10-10 07:58 ulm Note Added: 0003833
2022-10-10 18:46 christos Assigned To => christos
2022-10-10 18:46 christos Status new => assigned
2022-10-10 18:46 christos Status assigned => resolved
2022-10-10 18:46 christos Resolution open => fixed
2022-10-10 18:46 christos Fixed in Version => HEAD
2022-10-10 18:46 christos Note Added: 0003834