View Issue Details

IDProjectCategoryView StatusLast Update
0000052file[All Projects] Generalpublic2018-12-10 21:02
Reportervitalyisaev2Assigned Tochristos 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version5.35 
Target VersionFixed in VersionHEAD 
Summary0000052: mp3 file is determined as "audio/mpegapplication/x-tar"
DescriptionHi, please consider this file:

➜ attachments git:(UCS-5425) file -v
file-5.35
magic file from /etc/magic:/usr/share/misc/magic
➜ attachments git:(UCS-5425) file --mime-type audio.mp3
audio.mp3: audio/mpegapplication/x-tar

I think that the expected result is "audio/mpeg".
Steps To ReproduceSources: ftp://ftp.astron.com/pub/file/file-5.35.tar.gz
Compiler: gcc 8.2
OS: Fedora 28
Additional InformationAlso I would like to notice that at the place were I work now we use libmagic in many services, and we're interested in high quality of mime-type detection. Our QA engineers maintain set of files of various formats. I think that this set can be used as a foundation for modern libmagic's CI pipeline, which hopefully will prevent from such kind of regression bugs. If you're interested, please let me know.

Kind regards,
Vitaly
TagsNo tags attached.
Attach Tags

Activities

vitalyisaev2

2018-11-15 15:31

reporter  

audio.mp3 (10,493 bytes)

christos

2018-12-10 21:02

manager   ~0000104

Can't reproduce with HEAD.

Issue History

Date Modified Username Field Change
2018-11-15 15:30 vitalyisaev2 New Issue
2018-11-15 15:31 vitalyisaev2 File Added: audio.mp3
2018-12-10 21:01 christos Assigned To => christos
2018-12-10 21:01 christos Status new => assigned
2018-12-10 21:02 christos Status assigned => resolved
2018-12-10 21:02 christos Resolution open => fixed
2018-12-10 21:02 christos Fixed in Version => HEAD
2018-12-10 21:02 christos Note Added: 0000104