View Issue Details

IDProjectCategoryView StatusLast Update
0000075file[All Projects] Generalpublic2019-04-07 18:05
ReporterwyldaAssigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.36 
Target VersionFixed in VersionHEAD 
Summary0000075: file-5.36: configure --enable-zlib actually disables Zlib
DescriptionIf "--enable-zlib" is explicitly given for configure, then "ZLIBSUPPORT" won't be set to 1, even if in my case I have:
enable_zlib=yes
ac_cv_header_zlib_h=yes
ac_cv_lib_z_gzopen=yes
I'm not a programmer, but i guess it is because of "elif" instead of "if"???

---snip---
if test "$enable_zlib" = "yes"; then
  if test "$ac_cv_header_zlib_h$ac_cv_lib_z_gzopen" != "yesyes"; then
    as_fn_error $? "zlib support requested but not found" "$LINENO" 5
  fi
elif test "$ac_cv_header_zlib_h$ac_cv_lib_z_gzopen" = "yesyes"; then
  $as_echo "#define ZLIBSUPPORT 1" >>confdefs.h
fi
---snip---
TagsNo tags attached.

Activities

christos

2019-04-07 18:05

manager   ~0003234

Fixed, thanks.

Issue History

Date Modified Username Field Change
2019-03-31 19:16 wylda New Issue
2019-04-07 18:05 christos Assigned To => christos
2019-04-07 18:05 christos Status new => assigned
2019-04-07 18:05 christos Status assigned => resolved
2019-04-07 18:05 christos Resolution open => fixed
2019-04-07 18:05 christos Fixed in Version => HEAD
2019-04-07 18:05 christos Note Added: 0003234