View Issue Details

IDProjectCategoryView StatusLast Update
0000258tcsh[All Projects] Generalpublic2021-07-05 10:41
ReporterajrAssigned Tochristos 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSmacOS Big SurOS Version11.2.3
Product Version6.22.03 
Target VersionFixed in Version6.23.00 
Summary0000258: ls-F and file expansion do not support 'ln=target' in LS_COLORS
DescriptionGNU ls and bash allow for 'ln=target' in LS_COLORS. This sets the color to that of the file pointed to while maintaining the '@' suffix. In tcsh it comes out as "argetm" since it assembles the color string as "\e[targetm".

Changes to tw.decls.h, tw.color.c, and tw.parse.c (attached) implements support for ln=target
Additional InformationDiffs can be seen at https://github.com/ajrosen/tcsh/commit/b516f30f4849267a1e953c4f3fa613805415bf82
TagsNo tags attached.

Activities

ajr

2021-04-10 17:08

reporter  

tw.parse.c (58,277 bytes)
tw.decls.h (5,030 bytes)
tw.color.c (13,267 bytes)

christos

2021-07-05 10:41

manager   ~0003626

committed, thanks!

Issue History

Date Modified Username Field Change
2021-04-10 17:08 ajr New Issue
2021-04-10 17:08 ajr File Added: tw.color.c
2021-04-10 17:08 ajr File Added: tw.decls.h
2021-04-10 17:08 ajr File Added: tw.parse.c
2021-07-05 10:41 christos Assigned To => christos
2021-07-05 10:41 christos Status new => assigned
2021-07-05 10:41 christos Status assigned => resolved
2021-07-05 10:41 christos Resolution open => fixed
2021-07-05 10:41 christos Fixed in Version => 6.23.00
2021-07-05 10:41 christos Note Added: 0003626