View Issue Details

IDProjectCategoryView StatusLast Update
0000360fileGeneralpublic2022-07-04 17:12
Reporterkloczek Assigned Tochristos  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version5.42 
Fixed in VersionHEAD 
Summary0000360: "file -N -f" print dot instead file name
DescriptionJust found that after upgrade I'm not able to build any rpm package because "file -N -f" prints in filst column of the output instead file name just ".".
Steps To ReproduceExample

[tkloczko@devel-g2v SPECS]$ find /home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64/ '!' -path '/home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64//usr/lib/debug/*.debug' -type f '(' -perm -0100 -or -perm -0010 -or -perm -0001 ')' -print
/home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64/usr/lib64/libusb-1.0.so.0.3.0
/home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64/usr/lib64/libusb-1.0.la

[tkloczko@devel-g2v SPECS]$ find /home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64/ '!' -path '/home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64//usr/lib/debug/*.debug' -type f '(' -perm -0100 -or -perm -0010 -or -perm -0001 ')' -print |file -N -f -
/: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=5dc726ff611aee897cb801d30ac1927f0434a46e, with debug_info, not stripped, too many notes (256)
/: libtool library file, ASCII text
[tkloczko@devel-g2v SPECS]$ file --version
file-5.42
magic file from /etc/magic:/usr/share/misc/magic

The same after downgrade to prev version

[tkloczko@devel-g2v SPECS]$ find /home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64/ '!' -path '/home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64//usr/lib/debug/*.debug' -type f '(' -perm -0100 -or -perm -0010 -or -perm -0001 ')' -print |file -N -f -
/home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64/usr/lib64/libusb-1.0.so.0.3.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=5dc726ff611aee897cb801d30ac1927f0434a46e, with debug_info, not stripped, too many notes (256)
/home/tkloczko/rpmbuild/BUILDROOT/libusb-1.0.26-2.fc35.x86_64/usr/lib64/libusb-1.0.la: libtool library file, ASCII text
[tkloczko@devel-g2v SPECS]$ file --version
file-5.41
magic file from /etc/magic:/usr/share/misc/magic
Additional InformationI've not changed anything except version between those two version in my build prcedure.
Part of my spec file which is building file package

%build
autoreconf -fiv
%configure \
        --disable-libseccomp \
        --disable-rpath \
        --disable-static \
        --enable-fsect-man5 \
        %{nil}
%make_build
TagsNo tags attached.

Activities

kloczek

2022-06-16 22:19

reporter   ~0003765

Looks like Fedora rolled back as well.
https://bugzilla.redhat.com/show_bug.cgi?id=2095871

christos

2022-07-04 17:12

manager   ~0003777

Dup of PR/358

Issue History

Date Modified Username Field Change
2022-06-14 22:21 kloczek New Issue
2022-06-16 22:19 kloczek Note Added: 0003765
2022-07-04 17:11 christos Assigned To => christos
2022-07-04 17:11 christos Status new => assigned
2022-07-04 17:12 christos Status assigned => resolved
2022-07-04 17:12 christos Resolution open => fixed
2022-07-04 17:12 christos Fixed in Version => HEAD
2022-07-04 17:12 christos Note Added: 0003777