View Issue Details

IDProjectCategoryView StatusLast Update
0000053file[All Projects] Generalpublic2018-12-10 21:07
ReporteranonymousAssigned Tochristos 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version5.35 
Target VersionFixed in VersionHEAD 
Summary0000053: Output is not always consistent with cso files
DescriptionWhen using the compression tool maxcso to compress PS2 iso files to cso files file(1) does not always recognize them as "Compressed ISO CD image" files and will sometimes recognize them as "data" instead. The files work fine in the PS2 emulator PCSX2 and when decompressed with maxcso they will match the original md5sum of the source iso.

$ file Atelier\ Iris\ *.cso
Atelier Iris - Eternal Mana [NTSC-U].cso: Compressed ISO CD image
Atelier Iris 2: Azoth of Destiny [NTSC-U].cso: data
Atelier Iris 3: Grand Phantasm [NTSC-U].cso: Compressed ISO CD image

$ file Atelier\ Iris\ *.iso
Atelier Iris - Eternal Mana [NTSC-U].iso: UDF filesystem data (version 1.5) ''
Atelier Iris 2: Azoth of Destiny [NTSC-U].iso: UDF filesystem data (version 1.5) ''
Atelier Iris 3: Grand Phantasm [NTSC-U].iso: UDF filesystem data (version 1.5) 'ATELIER_IRIS_GF'

I asked the maxcso developer about this issue his response can be seen in this github issue, in short the assumptions file(1) is making about cso files is not always correct.

https://github.com/unknownbrackets/maxcso/issues/26

Unfortunately due to legal reasons I can not provide example files.
Steps To ReproduceThis can be reproduced by compressing various PS2 iso files with maxcso.

https://github.com/unknownbrackets/maxcso/
TagsNo tags attached.
Attach Tags

Activities

christos

2018-12-10 21:07

manager   ~0000105

Added the popular 0x4000 blocksize.

Issue History

Date Modified Username Field Change
2018-11-24 07:39 anonymous New Issue
2018-12-10 21:07 christos Assigned To => christos
2018-12-10 21:07 christos Status new => assigned
2018-12-10 21:07 christos Status assigned => resolved
2018-12-10 21:07 christos Resolution open => fixed
2018-12-10 21:07 christos Fixed in Version => HEAD
2018-12-10 21:07 christos Note Added: 0000105