View Issue Details

IDProjectCategoryView StatusLast Update
0000054file[All Projects] Generalpublic2018-12-10 21:09
ReporteranonymousAssigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.33 
Target VersionFixed in VersionHEAD 
Summary0000054: Berkeley DB file detection error
DescriptionWhile trying file on a Berkeley DB file (detected as 'Berkeley DB (Btree, version 9, native byte-order)' with file 5.32), I get this result with file 5.33: ', created: Thu Jan 1 00:38:24 1970'. This issue seems to be solved in file-5.34, but my distro uses 5.33.
Steps To Reproducerun `file` on the attached file.
Additional InformationI found this issue while compiling diffoscope with python-file instead of python-magic. One of the tests (where I found the attached file) fails because the file is not recognised correctly. For now, I've simply disabled the test to be able to build that tool, but it's not ideal.

GuixSD (my distro) cannot update file to a newer version before at least a few months because it requires rebuilding the whole set of packages. However, we can apply patches to the 5.33 version to fix this issue. If there is any patch you can point us to, we can still apply it without having to rebuild everything. Thank you!
TagsNo tags attached.
Attach Tags

Activities

anonymous

2018-11-25 11:46

reporter  

test1.db (32,768 bytes)

anonymous

2018-12-10 00:26

reporter   ~0000102

https://cbdoilamericano.com/# where to buy cbd cream for pain
https://cbdoilamericano.com/#
https://cbdoilamericano.com/#

christos

2018-12-10 21:09

manager   ~0000106

You can always compile a newer version of file; even if I fix 5.33, it is uncertain if your upstream will pick up the changes. Thanks for the report anyway.

Issue History

Date Modified Username Field Change
2018-11-25 11:46 anonymous New Issue
2018-11-25 11:46 anonymous File Added: test1.db
2018-12-10 00:26 anonymous Note Added: 0000102
2018-12-10 21:08 christos Assigned To => christos
2018-12-10 21:08 christos Status new => assigned
2018-12-10 21:09 christos Status assigned => resolved
2018-12-10 21:09 christos Resolution open => fixed
2018-12-10 21:09 christos Fixed in Version => HEAD
2018-12-10 21:09 christos Note Added: 0000106