View Issue Details

IDProjectCategoryView StatusLast Update
0000112file[All Projects] Generalpublic2019-10-08 20:25
ReporterconnescAssigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.37 
Target VersionFixed in VersionHEAD 
Summary0000112: Incorrect output with -iz on gzip file
DescriptionStarting with v5.37, combining -i and -z leads to incorrect results for gzip files.

Running it on a gzipped text file produces: text/plain; charset=us-ascii compressed-encoding=application/octet-stream; charset=binary
Versions bellow v5.37 produce what I would expect: text/plain; charset=us-ascii compressed-encoding=application/x-gzip; charset=binary
Steps To Reproduce# Create a simple test file
gzip <<< 'Hello World!' > hello.txt.gz

# Call file 5.37 with -i and -z
file -biz hello.txt.gz
Additional InformationI guess that gzip is properly detected since it is reported without -i. Only the MIME output seems to be broken.

Also, I get a correct output when using the v5.37 binary with the v5.36 magic file.
TagsNo tags attached.

Activities

christos

2019-10-08 20:25

manager   ~0003314

Fixed, thanks!

Issue History

Date Modified Username Field Change
2019-10-06 13:43 connesc New Issue
2019-10-08 20:25 christos Assigned To => christos
2019-10-08 20:25 christos Status new => assigned
2019-10-08 20:25 christos Status assigned => resolved
2019-10-08 20:25 christos Resolution open => fixed
2019-10-08 20:25 christos Fixed in Version => HEAD
2019-10-08 20:25 christos Note Added: 0003314