View Issue Details

IDProjectCategoryView StatusLast Update
0000173file[All Projects] Generalpublic2020-08-09 16:41
ReporterSascha BrawerAssigned Tochristos 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version5.39 
Target VersionFixed in Version5.40 
Summary0000173: Recognize E57 files
DescriptionCould libmagic recognize E57 files, used to store three-dimensional models, typically from laser scanners?

E57 files start with the magic eight byte sequence x'41 53 54 4D 2D 45 35 37'; or in ASCII: "ASTM-E57".
MIME type: model/e57
MIME registration: https://www.iana.org/assignments/media-types/model/e57
File extension: .e57
Sample files: http://www.libe57.org/data.html
Reference implementation: http://www.libe57.org/
File format overview: https://www.ri.cmu.edu/pub_files/2011/1/2011-huber-e57-v3.pdf

The libmagic configuration will probably look similar to the following:
#########
0 string ASTM-E57 ASTM E57 three-dimensional model
!:mime model/e57
!:ext e57
#########

Thank you in advance! Best regards,

— Sascha Brawer, sascha@brawer.ch
TagsNo tags attached.

Activities

Sascha Brawer

2020-07-27 13:51

reporter   ~0003438

Or maybe just this, since it’s shorter:
#########
0 string ASTM-E57 E57 model
!:mime model/e57
!:ext e57
#########

christos

2020-08-09 16:41

manager   ~0003441

Fixed, thanks!

Issue History

Date Modified Username Field Change
2020-07-25 18:57 Sascha Brawer New Issue
2020-07-27 13:51 Sascha Brawer Note Added: 0003438
2020-08-09 16:41 christos Assigned To => christos
2020-08-09 16:41 christos Status new => assigned
2020-08-09 16:41 christos Status assigned => resolved
2020-08-09 16:41 christos Resolution open => fixed
2020-08-09 16:41 christos Fixed in Version => 5.40
2020-08-09 16:41 christos Note Added: 0003441