View Issue Details

IDProjectCategoryView StatusLast Update
0000002file[All Projects] Generalpublic2018-08-01 09:04
ReporterHugal31Assigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000002: Too much false positive for DIY-Thermocam format
DescriptionI think the DIY-Thermocam format in the "measure" magic file is unwell defined and causes too many false positives.
For example :

# V1 or Lepton 2.x
9608 byte <19
>9600 use diy-thermocam-checker
>>9600 default x (Lepton 2.x),
>>>9600 use diy-thermocam-parser

A file with the byte 3840 set to 0xFF, for example, will trigger the first line, because it will be resolved as signed "-1", and "-1 < 19" is true.
I believe this behaviour is incorrect and can be solved by using "ubyte" and "ulefloat".
The same applies to the other rules, where I think changing the signed condition to an unsigned would greatly reduce the number of false positives.


I don't know the DIY-Thermocam format, and it was added by someone named "Harald Geyer". If someone know the file format or know how to contact him, please help to fix this magic file.
Steps To ReproduceUse underflow to trigger some rules. See file attached for example.
TagsNo tags attached.
Attach Tags

Activities

Hugal31

2018-06-12 09:33

reporter  

measure-fake.bin (9,621 bytes)

christos

2018-06-23 16:13

manager   ~0000005

Fixed as suggested

christos

2018-08-01 09:04

manager   ~0000026

feedback timeout

Issue History

Date Modified Username Field Change
2018-06-12 09:33 Hugal31 New Issue
2018-06-12 09:33 Hugal31 File Added: measure-fake.bin
2018-06-23 16:13 christos Assigned To => christos
2018-06-23 16:13 christos Status new => assigned
2018-06-23 16:13 christos Status assigned => feedback
2018-06-23 16:13 christos Note Added: 0000005
2018-08-01 09:04 christos Status feedback => resolved
2018-08-01 09:04 christos Resolution open => fixed
2018-08-01 09:04 christos Note Added: 0000026