View Issue Details

IDProjectCategoryView StatusLast Update
0000211file[All Projects] Generalpublic2020-12-17 20:45
ReporterAlbrechtAssigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS VersionBullseye
Product Version5.38 
Target VersionFixed in Version5.40 
Summary0000211: running file terminates with “ERROR: error reading”
DescriptionRunning file on the attached sample file terminates with

albrecht@deneb:/tmp$ file file-error-sample ; echo $?
file-error-sample: ERROR: error reading (Invalid argument)
1

Guessing the MIME type is successful, though:

albrecht@deneb:/tmp$ file --mime-type file-error-sample ; echo $?
file-error-sample: application/x-executable
0
Steps To Reproduce1. extract the attached archive
2. run commands as above
TagsNo tags attached.

Activities

Albrecht

2020-11-17 08:13

reporter  

file-error-sample.zip (1,415 bytes)

christos

2020-12-16 23:50

manager   ~0003507

I can't reproduce it:

[6:46pm] 109>./file -m ../magic/magic.mgc error_sample.zip
error_sample.zip: Zip archive data, at least v2.0 to extract
[6:46pm] 110>./file -v
file-5.39
magic file from /usr/local/share/misc/magic
[6:49pm] 115>/usr/bin/file -v
file-5.38
magic file from /etc/magic:/usr/share/misc/magic
[6:49pm] 116>/usr/bin/file error_sample.zip
error_sample.zip: Zip archive data, at least v2.0 to extract
[6:49pm] 117>uname -a
Linux uranus 5.4.0-56-generic 0000062-Ubuntu SMP Mon Nov 23 19:20:19 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Albrecht

2020-12-17 08:01

reporter   ~0003512

Umm, sorry, please do not use the ZIP itself, but its extracted contents – I didn't want to post an executable as plain file. I.e. something like:

albrecht@deneb:/tmp$ unzip file-error-sample.zip
Archive: file-error-sample.zip
  inflating: file-error-sample
albrecht@deneb:/tmp$ file file-error-sample
file-error-sample: ERROR: error reading (Invalid argument)

christos

2020-12-17 20:45

manager   ~0003513

Fixed in HEAD: ./file -m ../magic/magic.mgc file-error-sample
file-error-sample: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), can't read section at -1, missing section headers at 7136

Issue History

Date Modified Username Field Change
2020-11-17 08:13 Albrecht New Issue
2020-11-17 08:13 Albrecht File Added: file-error-sample.zip
2020-12-16 23:45 christos Assigned To => christos
2020-12-16 23:45 christos Status new => assigned
2020-12-16 23:50 christos Status assigned => feedback
2020-12-16 23:50 christos Note Added: 0003507
2020-12-17 08:01 Albrecht Note Added: 0003512
2020-12-17 08:01 Albrecht Status feedback => assigned
2020-12-17 20:45 christos Status assigned => resolved
2020-12-17 20:45 christos Resolution open => fixed
2020-12-17 20:45 christos Fixed in Version => 5.40
2020-12-17 20:45 christos Note Added: 0003513