View Issue Details

IDProjectCategoryView StatusLast Update
0000213file[All Projects] Generalpublic2021-03-28 19:03
ReporterMikhail.KovalevAssigned Tochristos 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionreopened 
Product Version 
Target VersionFixed in Version5.40 
Summary0000213: Chiasmus encrypted files (.xia)
DescriptionChiasmus (https://www.bsi.bund.de/EN/Topics/OtherTopics/Chiasmus/Chiasmus_node.html) is encryption software used by many public authorities in Germany. It would be great if file library could detect .xia files.
Additional InformationDetection should be easy: the first characters in the file are always "XIA". An example file is attached.
TagsNo tags attached.

Activities

Mikhail.Kovalev

2020-11-30 16:50

reporter  

example.xia (338 bytes)

christos

2020-12-17 00:04

manager   ~0003510

Added, thanks!

Mikhail.Kovalev

2021-03-25 11:43

reporter   ~0003574

I am really sorry, but this turned out to be a duplicate. Detection of Chiasmus files was already implemented in https://github.com/file/file/blob/master/magic/Magdir/bsi
So the newly added file https://github.com/file/file/blob/master/magic/Magdir/crypto should be removed.

The problem is that it's only the "textual description" which gets set if the file type is detected. But the MIME-type remains "application/octet-stream". Which indeed should be the case according to https://datatypes.net/open-xia-files
However, in the past there were some attempts to introduce special MIME types for Chiasmus files, e.g. from https://bugs.freedesktop.org/show_bug.cgi?id=23255:
- application/x-chiasmus-key Chiasmus key
- application/x-chiasmus-encrypted Chiasmus encrypted data

Would it be possible to add such MIME types to the File library?

christos

2021-03-28 19:03

manager   ~0003579

removed contents from crypto

Issue History

Date Modified Username Field Change
2020-11-30 14:52 Mikhail.Kovalev New Issue
2020-11-30 14:52 Mikhail.Kovalev File Added: test_file.xia
2020-11-30 16:50 Mikhail.Kovalev File Added: example.xia
2020-11-30 17:28 christos File Deleted: test_file.xia
2020-12-17 00:04 christos Assigned To => christos
2020-12-17 00:04 christos Status new => assigned
2020-12-17 00:04 christos Status assigned => resolved
2020-12-17 00:04 christos Resolution open => fixed
2020-12-17 00:04 christos Fixed in Version => 5.40
2020-12-17 00:04 christos Note Added: 0003510
2021-03-25 11:43 Mikhail.Kovalev Status resolved => feedback
2021-03-25 11:43 Mikhail.Kovalev Resolution fixed => reopened
2021-03-25 11:43 Mikhail.Kovalev Note Added: 0003574
2021-03-28 19:03 christos Status feedback => resolved
2021-03-28 19:03 christos Note Added: 0003579