View Issue Details

IDProjectCategoryView StatusLast Update
0000382fileGeneralpublic2022-10-09 05:15
ReporterMarv Assigned Tochristos  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.43 
Fixed in VersionHEAD 
Summary0000382: dsd64-dsf test fails with musl C library
DescriptionWhen updating file from 5.42 to 5.43 on a system using the musl libc (version 1.2.3) the following test failure surfaced:
```
Running test: ../tests/dsd64-dsf.testfile
../tests/dsd64-dsf.testfile: DSD Stream File, mono, simple-rate, 1 bit, 141184 samples
test: ERROR: result was (len 57)
DSD Stream File, mono, simple-rate, 1 bit, 141184 samples
expected (len 94)
DSF audio bitstream data, 1 bit, mono, "DSD 64" 2822400 Hz, no compression, ID3 version 2.3.0
make[2]: *** [Makefile:738: check-local] Error 1
```

It seems like the wrong magic information is picked since there are multiple definitions for "DSD\x20" at position 0:
```
magic/Magdir/dsf:7:0 string DSD\x20 DSD Stream File,
magic/Magdir/audio:1230:0 string DSD\x20 DSF audio bitstream data
```

Any advice how to track this down further is appreciated as I'm not familiar with the codebase

Best regards,
Marvin
Steps To ReproduceBuild using the musl libc

I used the following configure invocation:
```
./configure --build=x86_64-pc-linux-musl --host=x86_64-pc-linux-musl --prefix=/usr/x86_64-pc-linux-musl --bindir=/usr/x86_64-pc-linux-musl/bin --sbindir=/usr/x86_64-pc-linux-musl/bin --libdir=/usr/x86_64-pc-linux-musl/lib --datadir=/usr/share --datarootdir=/usr/share --docdir=/usr/share/doc/file-5.43 --infodir=/usr/share/info --mandir=/usr/share/man --sysconfdir=/etc --localstatedir=/var/lib --disable-dependency-tracking --disable-silent-rules --enable-fast-install --enable-bzlib --enable-xzlib --enable-zlib --disable-libseccomp --disable-static
```
TagsNo tags attached.

Activities

christos

2022-09-27 19:08

manager   ~0003819

Merged duplicate entries.

Issue History

Date Modified Username Field Change
2022-09-15 14:32 Marv New Issue
2022-09-27 19:08 christos Assigned To => christos
2022-09-27 19:08 christos Status new => assigned
2022-09-27 19:08 christos Status assigned => resolved
2022-09-27 19:08 christos Resolution open => fixed
2022-09-27 19:08 christos Fixed in Version => HEAD
2022-09-27 19:08 christos Note Added: 0003819