View Issue Details

IDProjectCategoryView StatusLast Update
0000436fileGeneralpublic2023-05-21 17:10
Reporterfstanchina Assigned Tochristos  
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.44 
Fixed in VersionHEAD 
Summary0000436: "file" reports incorrect line ending for a file with CR on 65536th byte
DescriptionI have a file that is reported as having "CRLF, CR line terminators":
```
$ file xxx/file.cpp
xxx/file.cpp: C source, ISO-8859 text, with CRLF, CR line terminators
```

After numerous attempts at re-saving it with uniform line terminators, it still reported an inconsistency.

Turns out that "file" reads at most 65536 bytes to check for encoding and such, and this particular file has a CR exactly on the 65536th byte. So "file" doesn't see the LF on the 65537th byte and reports an inconsistency.

This is obviously not a big problem, but I believe it's worth fixing if possible.
TagsNo tags attached.

Activities

christos

2023-05-21 17:10

manager   ~0003934

Dup of PR/444

Issue History

Date Modified Username Field Change
2023-03-23 15:17 fstanchina New Issue
2023-05-21 17:09 christos Assigned To => christos
2023-05-21 17:09 christos Status new => assigned
2023-05-21 17:10 christos Status assigned => resolved
2023-05-21 17:10 christos Resolution open => fixed
2023-05-21 17:10 christos Fixed in Version => HEAD
2023-05-21 17:10 christos Note Added: 0003934