View Issue Details

IDProjectCategoryView StatusLast Update
0000073file[All Projects] Generalpublic2019-04-09 18:34
ReporterenkeliAssigned Tochristos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.36 
Target VersionFixed in Version5.37 
Summary0000073: Reports Zip archive data for data with only one PK central dir signature
DescriptionFile reports for the attached file "Zip archive data".

$ file data-not-zip
data-not-zip: Zip archive data

The only ZIP-like thing it contains is 0x06054b50 and it does not seem sufficient to me to mark it as ZIP.

File hexdump:
00000000: 0000 0000 0000 0000 0000 0000 0000 0000 ................
00000010: 0000 0000 0000 0000 0000 0000 0000 0000 ................
00000020: 0000 0000 0000 0000 0000 0000 0000 0000 ................

file v. 5.30 reports "data" which seems more precise to me
00000030: 0000 0000 0000 0000 0000 0000 0000 0000 ................
00000040: 0000 0000 0000 0000 0050 4b05 0600 0000 .........PK.....
00000050: 0000 0000 0000 0000 0000 0000 0000 000a ................
TagsNo tags attached.

Activities

enkeli

2019-03-20 09:21

reporter  

data-not-zip (408 bytes)
00000000: 0000 0000 0000 0000 0000 0000 0000 0000  ................
00000010: 0000 0000 0000 0000 0000 0000 0000 0000  ................
00000020: 0000 0000 0000 0000 0000 0000 0000 0000  ................
00000030: 0000 0000 0000 0000 0000 0000 0000 0000  ................
00000040: 0000 0000 0000 0000 0050 4b05 0600 0000  .........PK.....
00000050: 0000 0000 0000 0000 0000 0000 0000 000a  ................
data-not-zip (408 bytes)

christos

2019-04-07 18:23

manager   ~0003235

Can't reproduce it:

[2:20pm] 2551>xxd -r ../data-not-zip >! ../data
[2:20pm] 2552>src/file -m magic/magic.mgc data
data: data
[2:20pm] 2553>hexdump -C data
00000000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
*
00000040 00 00 00 00 00 00 00 00 00 50 4b 05 06 00 00 00 |.........PK.....|
00000050 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0a |................|
00000060
[2:20pm] 2554>src/file -v
file-5.36
magic file from /usr/local/share/misc/magic

enkeli

2019-04-09 09:32

reporter   ~0003240

Sorry, I've probably uploaded wrong file.

This one is definitely reported as ZIP (close this issue if I'm wrong). I'd expect "data" or something other than ZIP.

$ sha256sum data-not-zip
a95a3e433275508dfbcfbea7ba83ff6b69d582be25dd0f3a87e2e9739b735d34 data-not-zip
$ file --version
file-5.36
magic file from /usr/share/file/misc/magic
$ file data-not-zip
data-not-zip: Zip archive data

data-not-zip-2 (102 bytes)
PK
data-not-zip-2 (102 bytes)

christos

2019-04-09 18:34

manager   ~0003242

Fixed, thanks

Issue History

Date Modified Username Field Change
2019-03-20 09:21 enkeli New Issue
2019-03-20 09:21 enkeli File Added: data-not-zip
2019-04-07 18:21 christos Assigned To => christos
2019-04-07 18:21 christos Status new => assigned
2019-04-07 18:23 christos Status assigned => new
2019-04-07 18:23 christos Note Added: 0003235
2019-04-09 09:32 enkeli File Added: data-not-zip-2
2019-04-09 09:32 enkeli Note Added: 0003240
2019-04-09 18:34 christos Status new => resolved
2019-04-09 18:34 christos Resolution open => fixed
2019-04-09 18:34 christos Fixed in Version => 5.37
2019-04-09 18:34 christos Note Added: 0003242